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Improvements and New Features in OSLO 7

Improvements in OSLO 7
e Improved STEP File Exporter
e Improved Zemax ® /OpticStudio ® importer
e Improved Code V® importer
e Feature Improvements
— Asymmetric Aspheres include base conic (OSLO Premium only)
— Help > Check for Updates
— Help > License
— Updated glass catalogs
New Features in OSLO 7

e New licensing using CodeMeter

New Videos for OSLO 7

New Examples Page on Website and Updated Manuals
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Improved STEP Export

e File>Export Lens to CAD

— Now Exports Conics, Aspheres, and almost all

lens types both for centered and decentered
systems

Export lens drawing to CAD ot

— Lens drawing style [DEF]

€ Meridional section " Sagittal section
€ End-on zection  wire frame
£ Solid model = Solid model [all surfaces)

— Lens drawing stle [[GES]
% perdional section € Sagittal section
€ End-on zection  Wire frame

— Drawing option
& Mome Al surfaces " Cross sections
€ Mo edges drawn " Obscurations drawn

First zurface I 1] Last zurface I 1]
OK | Cancel |  Hel

Confidential & Proprietary — Lambda Research Corporation -



STEP Export from the Shafer 5 Mirror system and then
imported into OSLO as a STEP file

@ Shafer Five-Mirror Objective [shafer3mirr.len] - O5LO Premium Early Access Build: 7.0.0.17016

File Lens Evaluste Optimize Tolerance Source Tools Window Help

BinEERO0@EE S

(===
of Command:

e 5|
2 Coardinates; Tilt and bend

[CGen ][ Setup |[wavelength |[ Field Points |[ variables || Draw off || Group |[ Notes |

Lens: Shafer Five-Mirror Objective Zoom 1 of 1
Ent beam radius 10.000000 Field angle 1.000000 Primary wavin 10. 000000
SRF RADIUS THICKNESS APERTURE RADIUS GLASS SPECTAL

000000 | 1.0000e+z0 [ | 1.7455e+ls arr [ | [
.z00000 | -160.200000 | 11.000000 [ | REFL_HaTcH[ |
900000 | 4s.es0000 [ |  4.000000 [ |REFL_HATCH [ |
75.940000 | -37.240000 | 10.000000 [ |REFL_HATCH[ |

810000 ] 39.240000 ] . 000000 REFL_HATCH [ ]
78.720000 | -74.so0000 [ 000000 [ |ReFL_waTcH [ ]

.ooooco | o.oooo000 [ 576320

|

n oo

v

-

B2 TracePro Brpert

File Edit View Geometry Define Raytrace Optimize Analysis Reports Tools Utilities Macros Window Help

DS H| S %8 o«
AR OB AR E |+

T
s

gk W EORBDE G @@ e ses
PR GE e H| [DABC

W o e R
Tz Bz Tx =¥ =5 & o

T UW1 - Lens Drawing ™ EI &
EiEe<z=a @i

Shafer FiveMirror Objective UNITS: M
OFTICAL SYSTEM LAYOUT DES: D. Shafer

= Model:[shaferSmirr.oml]

[

.~ OSL0 Lens 1 REFL_HATCH
~ OSLO Lens 2 REFL_HATCH
0SLO Lens 3 REFL_HATCH
0SLO Lens 4 REFL_HATCH

OSLO Lens 5 REFL_ HATCH]

Model [ Source [Radiance|
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Improved Zemax/OpticStudio Importer

e File>Import Lens File>Zemax

— Will attempt to import every Zemax commands and will report any problems on
import to the text window. Older importer would stop on the first non-recognized
command.

@ Double Gauss, 30mm /2 20deg [dblgauss.len] - O5L0 Premium Early Ao

File Lens Evaluate Optimize Tolerance Source Tools  Window

Mew Lens... Ctrl+M
Open Lens... Ctrl+0
Save Lens Ctrl+5

Save Lens As...

Load Command File...

Lens Database »
Import Lens File... » GEMII
Export Lens to CAD.. SIGMA

Open Database... \ CODEV
Print Text Window... L
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Steps to use Zemax/OpticStudio Importer

e Step 1 — Close the Surface Data Spreadsheet

e Step 2 — File>Import Lens File>Zemax

e Step 3 —Look in the

Text window for error
Messages

e Step 4 — Check the graphic
windows to make sure that

all rays passed through the
System

e Step 5 — Check that

Apertures are set correctly

@ [Untitled lens] - OSLO Premium Early Access Build: 7.0.0.17016

File Lens Evaluate Optimize Tolerance Source Tools Window Help

= e TPy ]

D

(SRR
_I

Iﬂlliﬂ
> |REN

@ Setup |[ Wavelength |[ Field Points |[ variables |[ oraw on ][ Group |[ Notes

Lens: DEMO SHOWS APLANATIC SOLVE Zo 1 0of 1 M 0.819570

Ent beam radius  0.750000 Field ang]e 5.7296e-05 Primary wavin  0.550000
SRE RADTUS THICKNESS APERTURE RADTUS GLASS SPECTAL
FEE] 0.000000 [ ]| 2.000000[ ] 2.0000e-08 ar[ ] []

-z.000000 | o.so0000[ | z.coo000[ A BKL —1

[z] -o.3003s0[s5] o.osoc00[ | 1.000000[ | awm[] [

[ 31 -3.szssza[ | o.sooo00[ | 1.400000[ | eaa[c] []

[ 4] -o.962952[5] o.oso000[F] 1.400000[ | ar[] [

[ 5] -6.5os413[ | o.soooco[ ] 1.700000 ] exa[c] [

[ 6] -2.ase163[s5] o.oso000[F] 1.700000 [ ] ar[ ] []

[ 7] -10.776910 ] o.soooco[ ] 1.s00000 [ ] EKL —1

[ 8] -4.292611[5] o.oso000[F] 1.s00000[ ] ar[ ] []

[ 2] -27.098s27[ | c.soocco[ | 2.000000 [ | BKL —1

[(10] -7.7#s113[s5]| o.os0000[F] z.ooo000[ | ar[_] [

-26.655631[ | o.soocc0[ |  z.oooooo[ | sal[c] [ ]

-13.212707[5] o0.034490[S] z.o00000[ | ar[ ] [

[13] 1s0.930138[ | o.sooooo[ |  z.oooo00 [ | BKL 1

[12] -24.602718[ | 1.o00000[ ]  2.000000 [ ] am[ ] []

[35] o.oo0000[ ] zo.o00000[ ] z2.eesssz[ s | ar[]
™S o.000000 ] o.oo0000 [ ] 21.210135 [ S| — v

DEMD SHOWS APLANATIC SOLVE
FOCAL LENGTH = O.8198 NA = 0.868

UNITS: M
DES: OSLe
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S [=r= s
B8 Len Spe Rin Ape Wav Pxc Abr Mg Ci Tra Sop Ref Fan Spd Auf e O e
~

ZLENS INPUT
SRE 0t
LID: DEMO smws APLANATIC SOLVE ?_—__—_—
UNT
UNT
E£8R 0.750000
WVF_REF_SPH_POS  Exit pupil
WAVLNS 0.550000
Wl 1.000000
SRE 01
v --
TH 2.000000
SRE 1:
AST 1
SRF 1:
v -0.500000
TH 0.500000
GLA BK1
MNOR command (marginal ray normal solve) not supported by OSLO
AP 1.000000
SRE 2:
v -0.663584
TH 0.050000
SRE 2:
ALC
aF 1.000000
SRE 3:
v -0.261129
TH 0.500000
GLA  BKL
MNOR command (marginal ray normal solve) not supported by OSLG
AP 1.400000
SRE 41
v -0.383751

0.050000
ALC

z
AP 1.400000
SRE 5:
v -0.151621 o




Second Example using Zemax/OpticStudio Importer

e Step 1 — Close the Surface Data Spreadsheet

e Step 2 — File>Import Lens File>Zemax

@ [Untitled lens] - O5LO Premium Early Access Build: 7.0.0.17016

File Lens Evaluate Optimize Tolerance Source Tools Window Help

BIESNZH@@Eas

(=@ ==
v o
x I =l
[Gen | Setup ][ Wavelength |[ Field Points ][ variables || Draw On_|[_Group | Notes |
Lens: THREE GLASS APOCHROMAT Zoom 1 of 1 EF1 100.000000
Ent beam radius 5.000000 Field angle 5.72962-05 Primary wavln 0.546000
RE RADIUS THICKNESS APERTURE RADIUS GLASS SPECTAL
OB] 0.000000 | 1.0000e+20[ | 1.0000e+14 am[_ ] [_]
90.488914 [ | 1.o000000 |  5.000000 ] [
[ 2] 1.4934e+03[__] 1.o00000[ ]  4.978768 KZFSE 1
23.440925 | z.o00000[ |  4.957207 FKS1 1
[ a] -63.o7rz432[_] s9s.sz7es4z |  4.941385 am[ ] [
o.000000 | o0.000000 ] O.000100 1
= Auto (== ==
THREE GLASS APOCHROMAT UNITS: WM
FOCAL LENGTH = 100 NA = .05 DES: OSLO
2.02
"
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EA Len Spe Rin Ape Wav Pxc Abr Mrg Chf Tra Sop Ref Fan Spd Af Vi Oue Be

=LENS INPUT
SRF 0:

LID: THREE GLASS APOCHROMAT
UNI m
UNI mm
EBR 5.000000
WVF_REF_SPH_FOS Exit pupil
WAVLNS 0. 404000
wv2 0. 480000
Wv3 0.546000
W4 0. 600000
W5 0. 656000
WW1 1.000000
WW2 1.000000
Ww3 1.000000
WW4 1.000000
WS 1.000000
WAVLNS 0. 546000
W1 1. 000000
Wv2 0. 404000
ww2 1.000000
Wv3 0. 480000
WW3 1.000000
Wva 0. 600000
Ww 1.000000
WS 0. 656000
WS 1.000000
SRF O:

cv -

TH 1.00008+20
SRF 1:

AST 1
SRF  1:

v 0.011051
TH 1.000000
GLA Fz

SRF 2

v 0.000670
TH 1.000000
GLA KZIFSE

SRF  3:

v 0.042660
TH 2.000000
GLA FKS1

SRF  4:

v -0.015855
TH 98.827642
SRF 5:

v -

TH --

END 5

OSLO



Improved CodeV Importer

e File=>Import Lens File->CodeV

— Will attempt to import every CodeV command
and will report any problems on import to the
text

@ Double Gauss, 30mm /2 20deg [dblgauss.len] - OSLO Premium Early Ace

File Lens Evaluate Optimize Tolerance Source Tools Window

Mew Lens... Ctrl+M
Open Lens... Ctrl+0
Save Lens Ctrl+5

Save Lens As..,

Load Cammand File...

Lens Database *

Import Lens File... » GEMII
Export Lens to CAD... \ SIGMA
Open Database... CODEV

Print Text Window... _—
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Steps to use CodeV Importer

e Step 1 — Close the Surface Data Spreadsheet

e Step 2 — File>Import Lens File>CodeV

@ [Untitled lens] - OSLO Premium Early Access Build: 7.0.0.17016

File Lens Evaluate Optimize Tolerance Source Tools Window Help

& HEEO %NS

e Step 3 - Look in the
Text window for error
Messages

e Step 4 — Check the graphi

[_setup |[ wavelength |[ Field Points |[ variables |[ braw off |[ Group |[ Notes
:Double Gauss - U.5. Patent 2,532 Zoom 1 of 1 EFl 104.128543
[ Field angle 14.000000 Primary wavin 0.656300

RADIUS THICKNESS APERTURE RADIUS

GLASS

.000000 [ | 9.9z9seriz[ | 2.4782e+11

aw[_]

8.746658 |
0.
12
3.776966 |

000000 [_]

BB Len Spe Rin Ape Wav Pxc Abr Mrg CHf Tra Sop Ref Fan Spd Auf Var

Windows to make sure that
all rays passed through the
System

e Step 5 — Check that

Apertures are set correctly
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BRS K@

| OOOOO0O00000C

Double Gauss - U.S. Patent 2,532
FOCAL LENGTH = 104.1 KA = O.2401

Sl

ZLENS INPUT
F 0O:

SNO2Z

Double Gauss - U.S. Patent 2,532,751

LID: Double Gauss - U.S. Patent 2,532

EER 25.000000

UNT mm

UNT mm

WAVLNS 0.656300

w2 0.587600

w3 0. 486100

W1 1.000000

ww2 1.000000

W3 1.000000

bEs %

ANG 14. 000000

SRF 0:

RD e

TH 9.9394e+11

GLA AIR

SRF  1:

RD 57.445765

TH 8.746658

IN GLA()

GLA  BK7

#UPDATE VARTABLES

VB CF TYP MIN MAX DAMPING INCR VALUE

WL 1 - o - = 1.000000 4.0000e-06 0.017407

END

SRF 2:

RD 188. 460067

H 0.298182

IN GLA()

GLA ATR

TUPDATE VARIABLES

VB SN CF TYP MIN MAX DAMPING INCR VALUE

v 2 2 - ov -- -- 1.000000 4.0000e-08 0.005306

END

ZUPDATE VARTABLES

VB SN CF TYP MIN MAX DAMPING INCR VALUE

v 3 2 - TH -- -- 1.000000 0.002500 0.298182

END

SRF 3:

RD 34.887272

TH 12. 424230

IN GLA()

GLA SK1

TUPDATE VARIABLES

VB CF TYP MIN MAX DAMPING INCR VALUE

v o4 E R = 5 1.000000 4.0000e-06 0.028664

END

SRF 4

RD

TH 3.

IN GLA()

GLA Fi5

SRF 5

RD 21. 463207

TH 15.107864

IN GLA()

GLA AIR

ZUPDATE VARTABLES

VB SN CF TYP MIN MAX DAMPING INCR VALUE

v 5 5 - o -- -- 1.000000 4.0000e-06 0.046578

END

LO




Second Example using CodeV Importer

e Step 1 — Close the Surface Data Spreadsheet

e Step 2 — File>Import Lens File>CodeV

@ [Untitled lens] - OSLO Premium Early Access Build: 7.0.0.17016

File Lens Evaluate Optimize Tolerance Source Tools Window Help

B 06 0 e s
t [= == [=][=]
B8 Len Spe fin Ape Wav Pxc Abr Nrg Chf Tra Sop Ref Fan Spd Auf
X STORED GLASS UNKNOWN
- = = = STORED GLASS UNKNOWN
[“Gen |[setup |[ wavelength |[ Field Points |[ variables |[ Draw off |[ croup |[ Notes | Reading C:\Users\Public\Documents\0sLO7 Premium Early Access\private/bin/glc/private.gic
Lens: Cassegrain Ritchey-Chretien Zoom 1 of 1 Ef1 1.7521e+03 writing C:\Users‘Public\Documents\O5L07 Premium Early Access\private/cdb/glass_private.cdb
Ent beam radius 0.600000 Primary wavin 0.632800
SRE RADIUS THICKNESS APERTURE RADIUS GLASS SPECIAL W
081 o.000000 | 1.0000e+10 | 1.0472e+08 ar[ ] S

74z.857200 | -z60.000000 | 75.000000 REFLECT | . i
- _ Cassegrain Ritchey-Chretien
290.232796 | 471.717084[ ] =22.500000[ ] RerLecT[] LID: Cassegrain Ritchey-Chretien

L1

-55.229670 ] .so0000 | 16.so01850[ s | SF11 1 EER 75.000000
=
1

[N

N
@

=] EBR ad
-118.498104 [ | .ooooo0 [ | 17.832237 am [ ] ;

UNT mm
f —0.0167 347 WAVLNS 0.632800
[mMs] o.oo0000[ ] -o0.o1evas[ | 18.347856 [ 5 | nhy ———
ANG 0.600000
-— i = SRE  0:
“. UW 1 - Lens Drawing E’ = P -
T TH  1.0000e+10
B IS e B« Ah ATh
. . . SRF 1:
Cassegrain Ritchey-Chretien LNITS: i RD  -742.857200
TH  -260.000000
FOCAL LENGTH = 1752 NA = 0.04281 DES: CsLO IN GLAQ
GLA REFLECT
AST 1
3 Command CON not recognized ##=*
-1.046192
L 2
75.000000
2:{
-290.232796
471.717084
IN GLA)

GLA REFLECT
#+* Command CON not recognized ##%

cC -2.915001
AP 22.500000
SRF 3:
RD -55.229670
TH 7.500000
1] IN GLAQ)
U GLA 5SF11
SRF 4:
RD -118.498104
TH 5.000000
IN GLA()
GLA AIR
SRF &
RD o,
TH -0.016718
GLA AIR
END 5
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Help Improvements — Check for Updates

e Help—>Check for Updates
— Shows the license type which is either fixed or network and Key Serial Number

— Has 3 buttons to Resolve, Refresh or Upgrade the license

HE'FP g} 05LO License Information *
O5L0 Help F1
TIFI of the DE}I' / -License Information
License... List of License Key(s): License Details:
Check for Updates... S b ety Ao B Ky,

0SLO network license,
Metwork light license seats: 1
About O5L0 Network standard license seats: 1
MNetwork premium license seats: 1
Temporary license expires on December 28, 2017,

Please select a license key from the list above to uparade or resalve.

Resolve Refresh Upgrade
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Help Improvements in Check for Updates - Resolve

e Help—>Check for Updates—Resolve

— Select this option to troubleshoot a licensing issue

HE|p g} O5L0 License Information
O5L0 Help F1
Tip of the Da}r / ~License Information
License... List of License Key(s): License Details:
Check for U pd ates... 2-2542454 Key Serial Mo: 2-2542464

This is a Lambda Research USE Key.

05LO network license,

About O5L0O Metwork light license seats: 1

Metwork standard license seats: 1

MNetwork premium license seats: 1

Temparary license expires on December 28, 2017,

[.\ Key serial no. 2-2542464 is functioning correctly.

oK

Please select g

Resalve Refresh Upgrade ]
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Help Improvements Check for Updates - Refresh

e Help—>Check for Updates—Refresh

— select this option to refresh the license information after connecting/disconnecting

USB keys or network connections

g} O5LO License Information

License Details:

Help
O5L0 Help F1
Tip of the Da}f ~License Information
’ List of License Key(s):
Lcetea 22542464
Check for Updates...
About O5L0

Reszolve

Please select a license key from the list ab

Key Serial Mo: 2-2542464

This is a Lambda Research USE Key.

C5LO network license,

Metwork light license seats: 1

Metwork standard license seats: 1

Metwaork premium license seats: 1

Temporary license expires on December 28, 2017.

upgrade or resolve,

Upgrade I
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Help Improvements Check for Updates - Upgrade

e Help—>Check for Updates—Upgrade

— select the license in the List of License Key(s), then select this option to open
another page of options related to making changes to the existing license

Help

OSLO Help 1
Tip of the Day /
License...

Check for Updates...

About OSLO

{8} 05LO License Information X

-License Information

List of License Key(s): License Details:

2-2542454 Key Serial Mo: 2-2542464

This is a Lambda Research USB Key,

05LO network license.,

Metwork light license seats: 1

Metwork standard license seats: 1

Metwork premium license seats: 1

Temporary license expires on December 28, 2017,

Please select a license key from the list above to upgrade or resolve.

Resolve Refresh Upgrade

ox
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Help Improvements Check for Updates — Upgrade Options

e Upgrade License - select this option to upgrade the

Current OSLO ||Cense (Change the OSLO Edltlon, add {8 05LO License Information X
time to a temporary license, etc) — this option sends an
Upgrade for key serial no. 2-2542464

e-mail to license@lambdares.com with a context file

taken from an existing license
gryngzrl';arﬁfeugiize:;grgzgnr:nclteoﬁrel:nsoggiéaﬁon to your license or are upgrading from a Uparade License ﬁ

If you would like to request a quote to upgrade the OSLO Edition or add licenses, select Purchase Upgrade k
current OSLO license (change the OSLO Edition, add

) . i i If you would like to send a receipt for an updated license, select Send Receipt
time to a temporary license, etc) — this option sends an 4

e Purchase Upgrade - select this option to upgrade the

e-mail to sales@lambdares.com with a context file

taken from an existing license

OK License List

e Send Receipt - select this option to send verification

that a license update has been activated (most
commonly used for a software key exchange) — this
option sends an e-mail to license@lambdares.com

with a context file taken from an existing license
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Help Improvements — Check for Updates

e Help—>Check for Updates

— Checks to see if a new version is available on the website

Help
O5L0 Help F1
Tip of the Day
License... /
Check for Updates...
About O5LO
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Updated Glass Catalogs

e Hikari

Hoya
e Ohara

Schott

Schott Radhard
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New OSLO Videos on the Lambda Research Website &
YouTube

e OSLO SCP - Video demonstrating how to create a simple SCP macro to output lens
parameters

e OSLO CCL for Lens Output - The first of three videos demonstrating how to create a
simple CCL macro to output lens parameters

e OSLO CCL for Lens Output Intermediate - The second of three videos demonstrating
how to create an intermediate CCL macro to output lens parameters

e OSLO CCL for Lens Output Complex - The third of three videos demonstrating how to
create a complex CCL macro to output lens parameters

e OSLO CCL Spiral Graphic Example Writing to the Graphics Window - An example
showing how to create a CCL macro writing to the graphics window.

e OSLO CCL Technical Example to Iterate through Field Points - A technical example
of a CCL macro with the particularly useful technique of sweeping through field points in
an analysis
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OSLO Examples Pages & Updated Manuals

e OSLO User Guide: - http://www.lambdares.com/imaqges/pdf/oslo-user-
quide.pdf

e OSLO Optics Reference - http://www.lambdares.com/images/pdf/oslo-

e OSLO Examples Page - http://www.lambdares.com/oslo/oslo-examples

— 31 new examples added

e OSLO Installers -
http://www.lambdares.com/CustomerSupportCenter/index.php/oslo/early-
access

— OSLO7EA Premium Installer.exe

— OSLO7EA Standard Installer.exe

— OSLO7EA Light Installer.exe
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